注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

风雨夜归人

专业收集资料,个人爱好!

 
 
 

日志

 
 

易语言全部的CALL资料总结  

2009-04-07 17:11:31|  分类: 外挂学习 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

一:先说直接调用CALL:

    动作:

    普通攻击:

        .版本 2

    置代码 ({  })

    mov_eax_常数 (十六到十 (#普攻CALL))

    call_eax ()

    ret ()

    代码 = _取代码 ()

    调用函数 (进程ID, 代码)

        使用技能:

  .版本 2

    置代码 ({  })

    pushad ()

    mov_eax_常数 (十六到十 (#技能CALL))

    push_常数 (-1)

    push_常数 (0)

    push_常数 (0)

    push_常数 (技能ID)

    mov_ecx_ptr (十六到十 (#全局基址))

    mov_edx_ptr_ecx加字节 (28)

    mov_ecx_ptr_edx加字节 (32)

    call_eax ()

    popad ()

    ret ()

    代码 = _取代码 ()

    调用函数 (进程ID, 代码)

使用物品:

.版本 2

置代码 ({  })

pushad ()

mov_ecx_常数 (物品ID)

mov_eax_常数 (物品序号)

push_常数 (1)

push_ecx ()

push_eax ()

push_常数 (0)

mov_eax_ptr (十六到十 (#全局基址))

mov_eax_ptr_eax加整数 (32)

mov_esi_eax ()

lea_ecx_ptr_eax加整数 (236)

mov_eax_常数 (十六到十 (#使用物品CALL))

call_eax ()

popad ()

ret ()

代码 = _取代码 ()

调用函数 (进程ID, 代码)

自动寻路:

.版本 2

置代码 ({  })

pushad ()

mov_eax_ptr (十六到十 (#全局基址))

mov_eax_ptr_eax加整数 (28)

mov_eax_ptr_eax加整数 (32)

mov_ebx_eax ()

mov_ecx_ptr_ebx加整数 (十六到十 (#走路偏移))

push_常数 (1)

mov_eax_常数 (十六到十 (#走路CALL1))

call_eax ()

mov_edi_eax ()

mov_eax_常数 (X)’整数型

mov_ptr_ecx加字节_eax (0)

mov_eax_常数 (Z)’整数型

mov_ptr_ecx加字节_eax (4)

mov_eax_常数 (Y)’整数型

mov_ptr_ecx加字节_eax (8)

push_ecx ()

push_常数 (F)’人在地面用0,空中水里用1

mov_ecx_edi ()

mov_eax_常数 (十六到十 (#走路CALL2))

call_eax ()

push_常数 (0)

push_常数 (1)

push_edi ()

mov_ecx_ptr_ebx加整数 (十六到十 (#走路偏移))

push_常数 (1)

mov_eax_常数 (十六到十 (#走路CALL3))

call_eax ()

popad ()

ret ()

代码 = _取代码 ()

调用函数 (进程ID, 代码)

取消NPC:

.版本 2

置代码 ({  })

pushad ()

push_常数 (十六到十 (#取消NPCCALL1))

mov_ecx_ptr (十六到十 (#全局基址))

mov_ecx_ptr_ecx加字节 (28)

mov_ecx_ptr_ecx加字节 (4)

mov_ecx_ptr_ecx加字节 (8)

mov_ecx_ptr_ecx加字节 (24)

mov_eax_常数 (十六到十 (#取消NPCCALL2))

call_eax ()

popad ()

ret ()

代码 = _取代码 ()

调用函数 (进程ID, 代码)

  

选怪:

.版本 2

            置代码 ({  })

            pushad ()

            mov_edi_常数 (怪物ID)

            mov_eax_ptr (十六到十 (#全局基址))

            push_edi ()

            mov_ecx_ptr_eax加字节 (32)

            add_ecx_常数 (236)

            mov_ebx_常数 (十六到十 (#选怪CALL))

            call_ebx ()

            popad ()

            ret ()

            代码 = _取代码 ()

            调用函数 (进程ID, 代码)

捡物:

.版本 2

            置代码 ({  })

            pushad ()

            mov_ecx_ptr (十六到十 (#全局基址))

            mov_eax_常数 (周围物品ID)

            push_eax ()

            mov_ecx_ptr_ecx加字节 (到字节 (32))

            mov_eax_常数 (周围物品序号)

            push_eax ()

            add_ecx_常数 (236)

            mov_eax_常数 (十六到十 (#捡物CALL))

            call_eax ()

            popad ()

            ret ()

            代码 = _取代码 ()

            调用函数 (进程ID, 代码)

二:用发包:比CALL要高一个层次,也比调用CALL要简单。

首先是发包CALL的调用:游戏中人物的各种动作都可以通过调用这个CALL来实现,你在你的外挂中只需要传入不同的包内容即可。

.版本 2

.子程序 call_发包

.参数 发包内容, 文本型

.局部变量 内容, 字节集

.局部变量 发包长度, 整数型

.局部变量 发包地址, 整数型

内容 = 字节集还原 (删全部空 (发包内容))

发包长度 = 取字节集长度 (内容)

发包地址 = 取字节集指针 (内容)

内存写字节集 (进程ID, 发包地址, 内容)

置代码 ({  })

pushad ()

mov_eax_ptr (十六到十 (#全局基址))

mov_ecx_ptr_eax加字节 (32)

push_常数 (发包长度)

push_常数 (发包地址)

mov_eax_常数 (十六到十 (#发包CALL))

call_eax ()

popad ()

ret ()

代码 = _取代码 ()

调用函数 (进程ID, 代码)

举个例子:你想打开NPC的话,先读游戏的内存得到NPC-ID,然后:

call_发包 (“2300” + 字节集查看 (到字节集 (NPC_ID), ))

即可。

各种发包的内容可以用OD截得:

一些常用的可以参考:

http://www.ghoffice.com/bbs/read-htm-tid-44149-keyword-%B7%A2%B0%FC.html

三。关于防封的问题:

  1.挂上不要有太多的关键字

  2.动态类名+动态标题。

  3.少用时钟.[这个主要是可以让外挂不至于太卡,以前见过有的人的挂,上面用了7.8个。寒。。。。]

    4.代码要尽量简单。[完美的反外挂系统包括特征码判断。]

  5.这个最重要,代码不要公开,外挂也不要公开,定期的重写代码,重设计窗口。

  

再附上178所用到的所有的基址:

.版本 2

.常量 全局基址, "“94C754”"

.常量 隐建, "“421138”"

.常量 跳跃, "“4509f5”"

.常量 穿墙, "“405189”"

.常量 视野, "“4056C7”"

.常量 技能CALL, "“4566C0”"

.常量 普攻CALL, "“5BCB10”"

.常量 选怪CALL, "“599D80”"

.常量 使用物品CALL, "“599B20”"

.常量 答题基址, "“94F7B4”"

.常量 走路CALL1, "“45E760”"

.常量 走路CALL2, "“462170”"

.常量 走路CALL3, "“45EB60”"

.常量 捡物CALL, "“599D10”"

.常量 发包CALL, "“59F330”"

.常量 取消NPCCALL1, "“8F9F1C”"

.常量 取消NPCCALL2, "“6F0D30”"

.常量 人物ID偏移, "“450”"

.常量 人物名偏移, "“5f0”"

.常量 人物级偏移, "“45C”"

.常量 帮派ID偏移, "“5BC”"

.常量 帮派名偏移, "“6D8”"

.常量 职业偏移, "“5F8”"

.常量 飞行打坐偏移, "“650”"

.常量 水陆空偏移, "“604”"

.常量 当前血偏移, "“464”"

.常量 当前蓝偏移, "“468”"

.常量 当前元偏移, "“478”"

.常量 最大血偏移, "“494”"

.常量 最大蓝偏移, "“498”"

.常量 物品包裹偏移, "“b80”"

.常量 装备包裹偏移, "“b84”"

.常量 任务包裹偏移, "“b88”"

.常量 宠物包裹偏移, "“c08”"

.常量 技能偏移, "“c18”"

.常量 走路偏移, "“bf4”"

.常量 目标偏移, "“a4c”"

.常量 红药冷却时间, "“988”"

.常量 蓝药冷却时间, "“990”"

  评论这张
 
阅读(564)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018