注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

风雨夜归人

专业收集资料,个人爱好!

 
 
 

日志

 
 

取文本字符数 3种方法  

2009-05-20 00:00:17|  分类: 易语言 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

方法1:

.版本 2

.子程序 GBK_取文本长度, 整数型
.参数 参数_被计算文本, 文本型
.局部变量 局部_文本长度, 整数型
.局部变量 局部_循环变量, 整数型
.局部变量 局部_当前文本, 文本型
.局部变量 局部_当前代码, 字节型
.局部变量 局部_字节属性, 整数型, , , 1:双字节第一个字节,2非双字节第一个字节
.局部变量 局部_字数, 整数型

局部_文本长度 = 取文本长度 (参数_被计算文本)
.变量循环首 (1, 局部_文本长度, 1, 局部_循环变量)
    局部_当前文本 = 取文本中间 (参数_被计算文本, 局部_循环变量, 1)
    局部_当前代码 = 到字节 (取代码 (局部_当前文本, ))

    .判断开始 (局部_当前代码 > 127 且 局部_字节属性 ≠ 1)  ' 汉字或者单字节结束
        局部_字节属性 = 1

    .判断 (局部_当前代码 > 31 且 局部_当前代码 < 127 且 局部_字节属性 ≠ 1)  ' 0~31及127(共33个)是控制字符或通讯专用字符,其余为可显示字符。
        局部_字节属性 = 2
        局部_字数 = 局部_字数 + 1

    .判断 (局部_字节属性 = 1)  ' 前边是半个汉字
        局部_字节属性 = 2
        局部_字数 = 局部_字数 + 1

    .默认

    .判断结束

.变量循环尾 ()

返回 (局部_字数)

 

方法2:

文本字符数=取文本长度 (到全角 (文本)) ÷ 2)

方法3:

文本字符数 = API_MultiByteToWideChar (0, 0, 文本 -1, {  }, 0)

.版本 2

.DLL命令 API_MultiByteToWideChar, 整数型, "kernel32.dll", "MultiByteToWideChar"
    .参数 CodePage, 整数型
    .参数 dwFlags, 整数型, , 0
    .参数 lpMultiByteStr, 文本型
    .参数 cchMultiByte, 整数型, , -1
    .参数 lpWideCharStr, 字节集, 传址
    .参数 cchWideChar, 整数型

  评论这张
 
阅读(698)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017